Sunday, July 20, 2014

Yongnuo YN-622N-TX Firmware Upgrade Example

When I posted my earlier videos on the 622N and 622N-TX, one of the requests from a user on flashhavoc.com was to post a similar step-by-step video on upgrading the firmware on the 622N-TX. I have finally gotten around to it and posted it below.


Nikon version that is covered in this video:
http://www.hkyongnuo.com/e-detaily.php?ID=339

Although I have not tried it myself, it appears from the manual that the process for the Canon 622C-TX is similar to the process for the 622N-TX, so for you Canon owners, here is the link to the 622C-TX page: http://www.hkyongnuo.com/e-detaily.php?ID=348

Please post any questions you have below, or in the video comments section, and I'll do my best to answer them.

Happy Shooting!

13 comments:

Clive said...

The Updater program is essentially the same for N and C YN updates. Canon users can find details on p.43, and a history on p.20, of TOYUG
https://docs.google.com/open?id=0B77OmmGIg0gMVFpqNkpBYXBHajA

David Carrico said...

@Clive,
Thank you for the info!
- David

John Tabor said...

Hey!

Would you mind sharing the user manual?

tknogeek at gmail

Thanks! :)

Richard Martinez said...

Hi David, I have a Nikon D5100 and I purchased the YN-565EX iTTL, as well as a pair of YN622N and a YN0622N-TX. I've read through the manuals as well as have seen several youtube vids including yours. Topic: shooting in iTTL mode. When I have the flash on the cameras hot shot, my exposures look correct. When I set up the flash on the triggers, it seems like the flash only operates at it's lowest power setting no matter what I do. I test the flash shooting the same subject on camera then from the same location, distance, height, et cetera, tested the flash off camera with the triggers / transceivers. Off camera in iTTL mode appears not to work. In iTTL I can hear the zoom head of the flash move when I zoom. My groups and channels are aligned. I set both the transceiver and trigger in iTTL. I've checked the firmware on the trigger. I really don't know what I might being doing wrong. Your help is greatly appreciated. richardrmartinezes@gmail.com

David Carrico said...

@Richard, The YN565N is listed by Yongnuo as a supported Flash. Have you checked the the flash is properly seated on the YN622N and the TX is properly seated on your camera?

Have you tried using it off camera, but essentially putting it near where it would reside on camera to rule out the camera seeing the light differently (I think you said you did this already)? Also, try going into spot meter mode and take two shots (one on camera and one like above where its off camera but held in roughly the same spot. Both shots should be spot metered off the same location.
Another avenue of inquiry if the flash is in TTL on the 622N, but you have set Manual on the TX is the power accurately changing? For instance, put your camera into manual 1/60 sec, ISO 200 and F8. Then take a test shot with the TX for the off camera flash set to 1/16 power, then one at 1/4 power and a 3rd at full power. Does it appear to be showing a change in Power setting. Now go back to setting the TX to iTTL, go into Aperture mode and try 3 shots, iTTL minus 1, iTTL 0 and iTTL +1. If you are seeing the exact same issues you've been seeing, you may have a hardware issue with your Yongnuos. Thanks and good luck!! Let me know what you find......

OlhosDeArgos said...

Hello David!

Recently bought a YONGNUO Yn 622n-TX, but the focus lamp does not work.
Already updated the firmware and I'm shooting Spot metering, as the manual.

Could you help me?

Thank you!

Jose Luis Carrillo said...

hi
I have a yn622n tx, I want to upgrade, but the wed of yongnuo not download the software, you would know where you can download.
Might you send me.
My yn622n tx, is new, and there are functions that do not perform well, I want to update it to check that it works well or not.
thx.
regards

Tow Ahm said...

Hello, David. I have been trying to update the firmware on my YN 622N TX for a long time now and your video helped me a lot to give me an idea on how to do it. However, none of the download links on the Yongnou website. Would you happen to have the files for firmware 1.06 and the updater software? Hope you can get back to me soon, thank you!

Chris said...

Glad to see others are having difficulty getting the firmware upgrade, too. Jose Luis or Tom did you ever have any luck?

Eli said...

Is there an upgrade from 1.06 for the YN 685N?

Unhappy said...

Absolutely impossible to update the firmware since I bought the 622 and a 568 last week. ....

Varun said...

any tips on how to get yn685 out of the wireless update mode?

Varun said...

any tips on how to get yn685 out of the wireless update mode?